User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Furrion surround sound doesn't work when watching TV

  1. #1
    New Member
    Join Date
    Apr 2014
    Location
    East Longmeadow, MA
    Posts
    18
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Furrion surround sound doesn't work when watching TV

    Just bought a brand-new 303RLS doing a shake down in the driveway of the electronics, having an issue with the Furrion DV1000. When I'm watching TV with the furrion stereo set to auxiliary the surround sound only works on the left speaker. When I set the Furrion to Stero or DVD both speakers work correctly. How do I get the right speaker to work. The balance is set to zero. I tested this on all three zones and I get the identical response only the left speaker works on zone A B or C. Any help would appreciated.

  2. #2
    Site Sponsor Steve and Cill's Avatar
    Join Date
    Sep 2013
    Location
    Georgia
    Posts
    1,368
    Blog Entries
    1
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Welcome to the forum Sersteve!

    I'm moving your thread to the Tech Area so maybe someone from GD will answer your question.

    Steve

  3. #3
    Site Sponsor Kordog's Avatar
    Join Date
    Feb 2014
    Posts
    172
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Check for a loose connection from the TV to the stereo. It works well on DVD because that is the source of the sound, but from the TV you have cables to feed the stereo and I bet you have a loose connection.
    Korey SE WI
    2014 Denali 3500HD LML DRW 4wd FS Airbags 20k Reese
    2014 Momentum 385TH #1396
    2013 Manitou SES VP 150hp Mercury 4 stroke
    Volunteer Firefighter Since 1997

  4. #4
    Member Tumbleweeds's Avatar
    Join Date
    Feb 2014
    Posts
    63
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Also, when you check, be sure the red and white RCA plugs are plugged into the receptacles closest to the antenna jack on the back of the sound system. It makes a big difference in controlling sound level.
    Mike and Suzanne with Smokey and Bandit
    Travel in Tumbleweed
    Reflection 303
    2013 Ram 2500 (Black Pearl), 4 x 4, Crew Cab, Cummins 6.7L Turbo Diesel. 6 Speed Auto
    PullRite 15K SuperGlide

  5. #5
    New Member
    Join Date
    Apr 2014
    Location
    East Longmeadow, MA
    Posts
    18
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Kordog View Post
    Check for a loose connection from the TV to the stereo. It works well on DVD because that is the source of the sound, but from the TV you have cables to feed the stereo and I bet you have a loose connection.
    I thought the same thing, that's what I checked first I unseated all connections and re seated them. Issue still exists.

  6. #6
    New Member
    Join Date
    Apr 2014
    Location
    East Longmeadow, MA
    Posts
    18
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Tumbleweeds View Post
    Also, when you check, be sure the red and white RCA plugs are plugged into the receptacles closest to the antenna jack on the back of the sound system. It makes a big difference in controlling sound level.
    Thanks for the clarification on the red and white RCA plugs, they are next to the antenna. I move them around to try different options but that set up you mentioned was the best quality but still with no right hand speaker on TV.

  7. #7
    Manufacturer
    Join Date
    Sep 2013
    Location
    Bristol & Middlebury, Indiana
    Posts
    1,298
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Sersteve View Post
    Just bought a brand-new 303RLS doing a shake down in the driveway of the electronics, having an issue with the Furrion DV1000. When I'm watching TV with the furrion stereo set to auxiliary the surround sound only works on the left speaker. When I set the Furrion to Stero or DVD both speakers work correctly. How do I get the right speaker to work. The balance is set to zero. I tested this on all three zones and I get the identical response only the left speaker works on zone A B or C. Any help would appreciated.
    Hi @Sersteve,

    Based on your description of the issue, there appears to be an internal issue with the Furrion DV1000. Please contact your dealer to schedule a service appointment to have this confirmed and addressed.

    Best regards,
    ~ Janice
    Mailing & shipping address: Grand Design RV, Attn: Customer Support, 13868 CR 4, Bristol IN 46507
    Hours: Monday - Friday (8:00 am - 5:00 pm EST, closed holidays)

    - Phones: Grand Design RV Corporate at (574) 825-8000 or Customer Support (direct) at (574) 825-9679
    - Fax: (574) 825-9249
    - Email: [email protected]
    - Website: www.granddesignrv.com

    - Facebook: https://www.facebook.com/GrandDesignRv
    - Twitter: https://twitter.com/granddesignrv
    - Google+: https://plus.google.com/113479014558069639097
    - LinkedIn: https://www.linkedin.com/company/grand-design-rv-llc
    - Vimeo: https://vimeo.com/granddesignrv
    - YouTube: https://www.youtube.com/channel/UCHa...PuUd3J3NHNyXVQ

    For EMERGENCY or immediate assistance contact your RV dealer or GDRV Customer Support directly at (574) 825-9679 with your 17-digit RV VIN, name, and phone number.

  8. #8
    I'm having same issue, just wondering if the new stereo worked?

  9. #9
    Senior Member redram's Avatar
    Join Date
    Apr 2014
    Location
    Spring/Texas
    Posts
    267
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    These things are a waste of money. Why they put them in i dont know. They say contact your dealer and get a time to fix HOW ABOUT CHRISTMAS that is what i was told. Should not be having this trouble anyway. I bought a DVD Blu Ray player for a bought $60.00 put in the cabinet next to the thing they call a DVD player. Don
    2014 Reflection 303//2013 Ram 2500 turbo diesel Spring, TEXAS

Similar Threads

  1. Furrion surround sound remote does not work
    By Tdietert13 in forum Electrical System and Wiring
    Replies: 4
    Last Post: 06-26-2014, 06:07 PM
  2. Removing Estone Surround Sound/Radio/DVD system
    By GaryLee in forum Electrical System and Wiring
    Replies: 8
    Last Post: 05-16-2014, 12:28 PM
  3. Upgraded my Surround Sound (or not) system
    By chris in forum Electrical System and Wiring
    Replies: 4
    Last Post: 12-06-2013, 08:02 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

DISCLAIMER:This website is not affiliated with or endorsed by Grand Design RV, LLC or any of its affiliates. This is an independent site.