User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Water Valve Issue

  1. #1
    Senior Member arhayes's Avatar
    Join Date
    May 2014
    Location
    RV Full-time
    Posts
    1,357
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Water Valve Issue

    We've had no problem with the Kantleak system until we got to the park we're in yesterday. I connected to their city service as usual and selected City Fixtures as I normally do. All seemed well, though I thought I heard water running. We had normal pressure in the rig and all seemed fine. I went out a little while later to discover the overflow on the fresh water tank was running, and it appears that I get City Fixture PLUS Freshwater Fill at the same time. Selecting Fill Tank seems to operate as normal. and selecting Normal runs water from the tank.

    Any quick suggestions? I'm assuming I've lost a seal in the valve that's allowing flow to both areas at once, but not sure. I have been using a 45 PSI restrictor, but it developed a leak in Elkhart and I have not been using it the last couple of stops until I can get a new one. We're in Tulsa, OK, in a city site so I assume the pressure is fairly normal and it doesn't seem excessive.

    Any ideas before I empty the fully loaded basement and try to tear into it? I've not contacted Customer Service yet, but will before I get into it. Too bad this didn't happen earlier as we were in Elkhart just last week and could have had it fixed there.
    Alan and Kathleen
    2015 Momentum 380TH (RVD2)
    2014 Ford F350 Dually (Stormtrooper)
    2012 Honda Goldwing Navi/ABS (Land Speeder)

  2. #2
    Senior Member
    Join Date
    Mar 2014
    Location
    Sumner, Michigan
    Posts
    182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Contact Customer Service - I think they have had problems with Anderson Kantleak possibly tearing up internal rubber seals. Mine had an internal milling issue.
    Jim and Cecille
    Sumner, MI
    2019 Solitude S-Class 2930RL #1098
    Used to be 2014 Reflection 337RLS #277
    2015 Chevy 2500HD Duramax 6.5' Box

  3. #3
    Senior Member arhayes's Avatar
    Join Date
    May 2014
    Location
    RV Full-time
    Posts
    1,357
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks. I sent a note late last night and will also call if I've not heard back. Tough not having water....
    Found water in the basement and had to unload it anyway. The pump screen cover wasn't attached and flooded the basement. Fixed that but still no water. Arrggghhh

  4. #4
    Site Sponsor
    Join Date
    Feb 2014
    Posts
    58
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I had this happen a few months ago. A rubber oring gets cut inside the valve. Have GD send you a new assembly.
    Julie and Kevin - Waterloo, IA
    2015 F-350 6.7L Lariat 4x4 SC, Edge Evolution CTS, B&W Companion.
    2015 337RLS

  5. #5
    Senior Member
    Join Date
    Mar 2014
    Posts
    539
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What's cutting the O rings? It's a great system if it's reliable.
    Nick and Nancy
    Abbotsford BC
    2011 Ram 3500
    2015 Reflection 303RLs

  6. #6
    Senior Member arhayes's Avatar
    Join Date
    May 2014
    Location
    RV Full-time
    Posts
    1,357
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    GD is shipping me a replacement. Apparently the original used a nylon ball that can become damaged easily. The one they're shipping has a brass ball that should last. Just one of those things, but they're taking care of it.
    Alan and Kathleen
    2015 Momentum 380TH (RVD2)
    2014 Ford F350 Dually (Stormtrooper)
    2012 Honda Goldwing Navi/ABS (Land Speeder)

Similar Threads

  1. Clog issue? Valve issue?
    By psyty4 in forum Plumbing and Water Systems
    Replies: 9
    Last Post: 07-12-2020, 09:51 PM
  2. Diesel Engine Battery Issue, GM Altenator non-issue
    By D2Reid in forum Tow Vehicles
    Replies: 7
    Last Post: 10-23-2017, 06:02 PM
  3. Replies: 7
    Last Post: 08-25-2017, 05:52 PM
  4. Slide issue? Door deadbolt issue
    By bosborn in forum Exterior
    Replies: 19
    Last Post: 08-11-2016, 10:39 AM
  5. Not a Westlake issue but a valve stem
    By dhshaw in forum General Tech Topics
    Replies: 11
    Last Post: 07-12-2016, 11:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

DISCLAIMER:This website is not affiliated with or endorsed by Grand Design RV, LLC or any of its affiliates. This is an independent site.