User Tag List

Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: No power to trailer, but I have power to front landing gear?

  1. #1
    Setting Up Camp
    Join Date
    Sep 2017
    Posts
    20
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    No power to trailer, but I have power to front landing gear?

    So I picked up my trailer out of storage today, drove home and opened the garage down below and turned the battery disconnect switch on to supply power to my trailer, and I got no power to the trailer and heard a clicking noise coming from the area around the battery disconnect switch and it also sounded like it was coming from behind the wall that separates the front storage from the garage area! Since my landing gear worked, but had no power to the rig, I checked all the circuit breakers...none were tripped! Once I turn the battery disconnect switch off, the clicking noise goes away! I went to camping world and bought a new battery disconnect switch, installed it and same problem!! So its not the disconnect switch! I am hooked up to 30amp power and still no power in the trailer...no lights, etc. etc!! What can I check to find the problem...are there relays or hidden circuit breakers behind walls? I have a 2015 303RLS. Need help...thanks!

  2. #2
    Site Team traveldawg's Avatar
    Join Date
    Aug 2017
    Location
    Florida Space Coast
    Posts
    1,760
    Blog Entries
    1
    Mentioned
    35 Post(s)
    Tagged
    0 Thread(s)
    Someone with a model like yours should chime in soon. In the meantime, there is power to the landing gear because it is taken from the batteries prior to the disconnect switch (me as break-away switch for the brakes).

    Did you measure the battery voltage? If it's low maybe something isn't quite connecting causing the noise.

    After the disconnect switch the 12v should go directly to the DC distribution panel (mine is inside the RV). It may be a bad connection.

    How about the groups? Did you check them to make sure they were still good?

    Probably need 2 people to trace the sound - one on the switch, one listening.
    Larry
    2018 F350 SRW SB - AirLift 5000 w/Wireless One; ForScan; 37gal RDS Fuel Tank; Demco Hikacker
    2019 310GK-R - Sailuns; MorRyde SRE4000; Disc Brakes (StopYourTrailer.com); Electric Cord Reel


  3. #3
    Setting Up Camp
    Join Date
    Sep 2017
    Posts
    20
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Thanks... I was wondering if that could possibly be the problem! My DC distribution relays, are mounted on the wall just above the battery! It does sound like it may be coming from there also! This may sound strange but everytime I hear the clicking noise, about every 5 seconds, the ground wire coming from the distribution panel to a ground screw mounted at the bottom of the panel JUMPS! It's like the clicking noise causes that wire to jolt! Do you think it might be the connection or the actual distribution bar/relay going bad? The sound is coming from that area definitely!

  4. #4
    Setting Up Camp
    Join Date
    Sep 2017
    Posts
    20
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Forgot to mention that the wires that are all connected to the distribution relays, appear to be tight... Couldn't move any of them!

  5. #5
    Site Sponsor
    Join Date
    Jul 2017
    Location
    SW Indiana
    Posts
    1,163
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)
    If it’s been stored for any length of time without power, your battery is dead. May be overloading the converter, especially if it was cold while in storage and the battery froze.
    Last edited by jkwilson; 03-18-2021 at 09:20 PM.
    John & Kathy
    2014 F250 Lariat FX4 6.2L SBCC
    2014 Reflection 303RLS
    SW Indiana

  6. #6
    Setting Up Camp
    Join Date
    Sep 2017
    Posts
    20
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    If that was the case...how was I able to raise the landing gear with a bad battery? I have power to the landing gear...just no power to the rest of the trailer when the battery disconnect switch is turned on! Do you think that the clicking noise is a dead giveaway of a bad battery??

  7. #7
    Seasoned Camper goodoz's Avatar
    Join Date
    Apr 2019
    Location
    Way South of Mason Dixon -- USA
    Posts
    125
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by cstratton73 View Post
    If that was the case...how was I able to raise the landing gear with a bad battery? I have power to the landing gear...just no power to the rest of the trailer when the battery disconnect switch is turned on! Do you think that the clicking noise is a dead giveaway of a bad battery??
    Are you saying your landing gear works (12V) but your lights (12V) don't work?
    GoodOz

    2019 Reflection 297RSTS
    2018 F250 6.7 w/2219 available payload

  8. #8
    Setting Up Camp
    Join Date
    Sep 2017
    Posts
    20
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    That is correct... My landing gear works fine but I have no power whatsoever to the trailer even with the battery disconnect turned on! Constant clicking noise about every 4-5 seconds once I turn the disconnect switch on...then goes away when I turn it off! No power to the trailer with the disconnect switch on! Replaced the disconnect switch with a new one and it did not fix the problem! Clicking noise appears to be coming from the distribution panel mounted on the wall above the battery! Pissing me off!!

  9. #9
    Site Sponsor gbkims's Avatar
    Join Date
    Mar 2017
    Location
    Pearland, TX
    Posts
    1,656
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by cstratton73 View Post
    Thanks... I was wondering if that could possibly be the problem! My DC distribution relays, are mounted on the wall just above the battery! It does sound like it may be coming from there also! This may sound strange but everytime I hear the clicking noise, about every 5 seconds, the ground wire coming from the distribution panel to a ground screw mounted at the bottom of the panel JUMPS! It's like the clicking noise causes that wire to jolt! Do you think it might be the connection or the actual distribution bar/relay going bad? The sound is coming from that area definitely!
    Appears there may be a short past the switch tripping one of the auto resetting circuit breakers.
    DC Auto Resetting CB Cutaway https://www.youtube.com/watch?v=vA1cz021OvU
    Attached Thumbnails Attached Thumbnails FW OEM Wiring - Electric Legs-1.pdf  
    - Gene

    Kim & Gene
    2015 Reflection 317RST
    2017 Ram 3500 CC LB 4x2 6.7 CTD AISIN 3.73 DRW Auto Level Rear Air, BD3, Prodigy P3, Aux Tank

  10. #10
    Setting Up Camp
    Join Date
    Sep 2017
    Posts
    20
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    There's no rodent damage... I have checked everything out! I don't know if it is a short or something wrong with the distribution panel! If one of the relays are bad, would that cause the sound I am hearing? I hate to take it in... They keep it for weeks and charge you hundreds of dollars for a $20 part! Maybe some spark chaser will see the thread tomorrow and have an idea! Thanks for the help... I'll keep at it until I find the problem! That's one thing I do well... Work The Problem!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

DISCLAIMER:This website is not affiliated with or endorsed by Grand Design RV, LLC or any of its affiliates. This is an independent site.