User Tag List

Results 1 to 5 of 5
  1. #1
    Fireside Member
    Join Date
    Mar 2021
    Location
    New England
    Posts
    60
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Potable water pump humming, but no water!

    We have a brand new 2021 Transend Xplor. We're testing all the systems before heading out on our first trip.
    For some reason, the potable water pump hums, but does not deliver water to the faucets.
    I'm wondering if there's a valve near/at the pump or within the water system that we need to open that we are unaware of? The dealer is NOT returning our calls regarding this issue.

    Here's a little additional info:
    - We flushed the system of anti-freeze from the winterization with success.
    - We tested the city water AND the hot water heater, with success.
    - We have a 3-valve water heater system. The valves ARE in the proper position.

    Thank you in advance for any insight.

  2. #2
    Site Sponsor NB Canada's Avatar
    Join Date
    Sep 2018
    Location
    Woodstock
    Posts
    2,260
    Mentioned
    41 Post(s)
    Tagged
    0 Thread(s)
    I assume you filled the fresh water tank?


    2021 Imagine 2400 BH
    2018 GMC Sierra 4x4 crew
    2021 Imagine 2400 BH
    2018 GMC Sierra 4x4 Crew 1840lb payload

  3. #3
    Fireside Member
    Join Date
    Mar 2021
    Location
    New England
    Posts
    60
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Haha! Good question NB Canada. Yes! We did fill the tank. I should have mentioned that.

  4. #4
    Setting Up Camp
    Join Date
    Dec 2020
    Location
    Greater Cincinnati
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Hiking Girl View Post
    We have a brand new 2021 Transend Xplor. We're testing all the systems before heading out on our first trip.
    For some reason, the potable water pump hums, but does not deliver water to the faucets.
    I'm wondering if there's a valve near/at the pump or within the water system that we need to open that we are unaware of? The dealer is NOT returning our calls regarding this issue.

    Here's a little additional info:
    - We flushed the system of anti-freeze from the winterization with success.
    - We tested the city water AND the hot water heater, with success.
    - We have a 3-valve water heater system. The valves ARE in the proper position.

    Thank you in advance for any insight.
    you said you flushed anti-freeze, was this with your city water hook up?
    assuming your fresh water tank filled, there is another set of valves at the pump so the pump can pull from the open end (where you would feed it the anti-freeze) and change it so it will draw from the fresh.
    -Rob M

    2021 Imagine XLS 21BHE "Wanda Travelmor"
    Everything we wanted in a trailer, nothing we didn't.

  5. #5
    Fireside Member
    Join Date
    Mar 2021
    Location
    New England
    Posts
    60
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello Rob!

    Yes! We flushed the anti-freeze with the city hook up.
    The fresh water tank IS filled. Now I just have to find the valves at the pump! I suspect they are under a dinette seat that is bolted. I'll have to check that out!

    Thank you SO much. I figured we were missing something.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

DISCLAIMER:This website is not affiliated with or endorsed by Grand Design RV, LLC or any of its affiliates. This is an independent site.