User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2
  1. #1
    Left The Driveway
    Join Date
    Jul 2019
    Location
    California
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Progressive Water Heater Failure - trips 7.5 Amp "Power Center" Fuse

    Long Time Lurker, 1st Time Poster
    I have a 2017 Reflection 303RLS with an Atwood Water HeaterClick image for larger version. 

Name:	Atwood WH Label.jpg 
Views:	10 
Size:	96.2 KB 
ID:	34189 that will not run - continually trips the 7.5 Amp "Power Center" fuse Click image for larger version. 

Name:	Updated Fuse Panel #11_7.5 Amp Power Center.jpg 
Views:	8 
Size:	89.8 KB 
ID:	34188
    Here's background details: 1st problem noticed in November, when dry camping. With WH on propane the electric would also kick on when ever I ran generator even with electric selector switch turned off. Camping with hook up in March WH ran ok on electric but fuse tripped at end of trip and did not realize it was WH. Just returned from hook up camping. WH on Electric tripped 7.5 amp "Power Center" fuse. WH would run on propane if I turned off 110v AC to WH for 1st day. Now fuse blows when ever WH is turned on, either propane or Electric.

    Has anyone else experienced this?
    Any suggestions on troubleshooting strategy?
    Northern California
    2004 Chevy Silverado 2500 HD 2WD 8100 Vortec
    2017 Reflection 303RLS (2016 Floorplan :^P)

  2. #2
    Left The Driveway
    Join Date
    Jul 2019
    Location
    California
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    UPDATE
    After opening up the pass through storage wall and kitchen cabinets I was able to visibly inspect the wiring and found no damage nor breaks. Tested continuity from Water Heater selector switches (Gas, Electric) to connectors at control board and found no shorts.
    Tested OHMs through (disconnected) Electric heating element - 10 Ohms as expected. Tested continuity through T-Stat and E.C.O. Stat - both good. Tested continuity from Stats to connectors at control board and found not shorts. Only suspect left was control board. Ordered/installed Dinosaur Electronics UIB 64 and all is working again.
    Northern California
    2004 Chevy Silverado 2500 HD 2WD 8100 Vortec
    2017 Reflection 303RLS (2016 Floorplan :^P)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

DISCLAIMER:This website is not affiliated with or endorsed by Grand Design RV, LLC or any of its affiliates. This is an independent site.