User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3
  1. #1
    Setting Up Camp
    Join Date
    Apr 2021
    Location
    Sw Georgia
    Posts
    15
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Rear camera no signal

    Hooked truck to our new Imagine xls 22 rbe today. We bought TT 3-4 weeks ago, also bought
    Furring vision s from dealer, they installed worked fined on drive home. Today my monitor reads no signal and the TT turn signals not working. Turn signals on truck work. Checked fuses in panel in TT all tested good. Any ideas? TIA
    2021 Imagine xls 22rbe
    2018 Silverado 5.3, auto crew cab

  2. #2
    Seasoned Camper more tired since retired's Avatar
    Join Date
    Oct 2019
    Location
    southern Georgia, where gnats rule the world
    Posts
    196
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by jjradtech View Post
    Hooked truck to our new Imagine xls 22 rbe today. We bought TT 3-4 weeks ago, also bought
    Furring vision s from dealer, they installed worked fined on drive home. Today my monitor reads no signal and the TT turn signals not working. Turn signals on truck work. Checked fuses in panel in TT all tested good. Any ideas? TIA
    Have you read the instructions that came with the system? In order for the camera to work, you must have your lights on. Doesn't matter if it's headlights or parking lights. Your automatic daytime driving lights will not do it. The camera draws power from the LIT marker lights.
    2020 F-250 Lariat 2WD SuperCrew Diesel and Blue Ox SwayPro hitch
    2020 Imagine 2600RB with Road Armor + wet bolt suspension, Yakima Longhaul Bike Rack,
    MicroAir EasyStart 364 for AC
    Amateur Radio Call N9XGZ
    FMCA # 489460
    I thought I was tired when I was working. Now that I'm retired I have even less time to do what I want. :cool:

  3. #3
    Fireside Member
    Join Date
    Nov 2017
    Location
    Guilford, IN
    Posts
    96
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by jjradtech View Post
    Hooked truck to our new Imagine xls 22 rbe today. We bought TT 3-4 weeks ago, also bought
    Furring vision s from dealer, they installed worked fined on drive home. Today my monitor reads no signal and the TT turn signals not working. Turn signals on truck work. Checked fuses in panel in TT all tested good. Any ideas? TIA
    I had an issue with a 7 prong pigtail that I use with my ProPride hitch 2 weeks ago. Somehow got damaged and I didn't have marker lights and backup camera didn't work. Checked my truck fuses. Had a 30 amp that blew. Check your truck owners manual for fuse locations and perform a continuity test on it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

DISCLAIMER:This website is not affiliated with or endorsed by Grand Design RV, LLC or any of its affiliates. This is an independent site.