User Tag List

Results 1 to 5 of 5
  1. #1
    Left The Driveway
    Join Date
    Oct 2020
    Location
    Oregon
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    No water pressure at the faucets

    Need help with a water pressure problem. On the 4th day camping and using city water hookup as usual, we lost all water pressure at the faucets. Everything okay from camp tap to the inlet at trailer, but just a trickle from faucets. Filled the Fresh water tank and flow from water pump is fine. Anyone have this happen? Don't know what could fail just on the City water side of the system. Does the water control handle just abruptly fail? No leaks anywhere. Any ideas for a fix before I contact dealer for repairs which will likely end our camping season while waiting.

    2021 XLS 17MKE

  2. #2
    Site Sponsor NB Canada's Avatar
    Join Date
    Sep 2018
    Location
    Woodstock
    Posts
    3,679
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)

    No water pressure at the faucets

    It wouldn’t be something to end your season

    Yes the valve could have failed. Is it filling your fresh tank up?

    Unhook the city water to alleviate the pressure and turn the valve back and forth the. Reattach and try

    The valve should never be turned when water is hooked up


    2021 Imagine 2400 BH
    2018 GMC Sierra 4x4 crew
    Last edited by NB Canada; 09-11-2021 at 07:56 AM.
    2021 Imagine 2400 BH
    2018 GMC Sierra 4x4 Crew 1840lb payload

  3. #3
    Left The Driveway
    Join Date
    Oct 2020
    Location
    Oregon
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I filled the fresh tank from the unpressurized side so don't know if it would fill from the valve side. I hadn't messed with the valve at all, I was in the kitchen washing some dishes when the pressure just dropped to a trickle. I'll cycle the valve with no hose hooked up and see what happens. Thanks, we can finish the season using the fresh water tank if we need to, don't want to wait on the shop to get to it.

    Has anyone replaced that valve or even removed it and just use the non-pressurize fill if using the fresh tank? connecting the city water line only to that intake?

  4. #4
    Rolling Along
    Join Date
    Mar 2021
    Posts
    585
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    If you are using one of those screw-on in-line pressure regulators like Camco, remove it and see if the problem goes away. Those things can cause a lot of problems.
    2010 Jayco 26(SOLD)
    2011 Keystone Outback 277RL(SOLD)
    2021 Grand Design 268BH
    2013 Ford F250 XLT, 6.2L Gas

  5. #5
    Site Sponsor
    Join Date
    Jul 2021
    Posts
    411
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Could be a clogged strainer in the supply line. Check at the city water connection, the inlets of water filters and pressure regulators often have screens. I’ve had this happen more than once.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

DISCLAIMER:This website is not affiliated with or endorsed by Grand Design RV, LLC or any of its affiliates. This is an independent site.