User Tag List

Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    Setting Up Camp
    Join Date
    May 2022
    Location
    Harvest, AL
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Innoflame Fire Place issues?

    Anyone have issues with their Innoflame Fireplace?

  2. #2
    Long Hauler
    Join Date
    May 2020
    Location
    All over - Full-timing
    Posts
    2,557
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by DohMan View Post
    Anyone have issues with their Innoflame Fireplace?
    No, but it would be helpful to know what issue(s) you are experiencing.
    Mark & Mary. Full-timing across the USA (and Canada)!
    Current Coach: 2021 Grand Design Reflection 320MKS
    Current Rig: 2019 Ford F350 SD Crew Cab, w/8' box, Lariat, SRW, 6.7l Diesel

  3. #3
    Setting Up Camp
    Join Date
    May 2022
    Location
    Harvest, AL
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Fireplace worked fine since we've owned the unit. Ran it for several hours one night. Went to turn it on the next AM and it comes on but no heat and it shows a "E1" fault which the manual says call for service. Was curious if anyone else exprerienced this. I tried to power it all the way down by turning off the breaker because I can't easily reach the plug. I left if disconnected for about 10 minutes. No effect. I'm curious if a "service manual exists" all I have is the owners manual which describes how to install it and operate it but nothing about fixing it.

  4. #4
    Long Hauler
    Join Date
    May 2020
    Location
    All over - Full-timing
    Posts
    2,557
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by DohMan View Post
    Fireplace worked fine since we've owned the unit. Ran it for several hours one night. Went to turn it on the next AM and it comes on but no heat and it shows a "E1" fault which the manual says call for service. Was curious if anyone else exprerienced this. I tried to power it all the way down by turning off the breaker because I can't easily reach the plug. I left if disconnected for about 10 minutes. No effect. I'm curious if a "service manual exists" all I have is the owners manual which describes how to install it and operate it but nothing about fixing it.
    I want and to find anything in the Internet regarding the E1 error and Innoflame directly. However, it appears that there are two possible issues.

    1. The control board is shot and needs to be replaced.
    2. The blower squirrel cage and duct is dirty and needs to be cleaned.

    Personally, I lean toward the first item.

    Unfortunately, I don't think Innoflame even has a service manual. In fact, I couldn't even find a manufacturers website for Innoflame.
    Mark & Mary. Full-timing across the USA (and Canada)!
    Current Coach: 2021 Grand Design Reflection 320MKS
    Current Rig: 2019 Ford F350 SD Crew Cab, w/8' box, Lariat, SRW, 6.7l Diesel

  5. #5
    Setting Up Camp
    Join Date
    May 2022
    Location
    Harvest, AL
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm figuring there is a thermal over heat cutoff component issue. E1 is and overheat alarm. The camper is under warranty so I'll let Grand Design deal with it which is probably gonna take awhile.

  6. #6
    Long Hauler
    Join Date
    May 2020
    Location
    All over - Full-timing
    Posts
    2,557
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by DohMan View Post
    I'm figuring there is a thermal over heat cutoff component issue. E1 is and overheat alarm. The camper is under warranty so I'll let Grand Design deal with it which is probably gonna take awhile.
    Call them at 08:00 (CST) tomorrow and have your VIN handy. When taking with them, see if they will authorize a mobile tech. If so, you probably can have it fixed within weeks instead of months.
    Mark & Mary. Full-timing across the USA (and Canada)!
    Current Coach: 2021 Grand Design Reflection 320MKS
    Current Rig: 2019 Ford F350 SD Crew Cab, w/8' box, Lariat, SRW, 6.7l Diesel

  7. #7
    New Member
    Join Date
    Jan 2023
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    My innoflame had an E3 code. Contacted GD and they did all the leg work to get a replacement (still under warranty) shipped out.

  8. #8
    Site Sponsor
    Join Date
    Feb 2016
    Location
    Houston (Humble area)
    Posts
    220
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    My experiences with these fireplaces, I'm on my third one now, is they are cheaply built and don't last. I had one replaced under warranty and Grand Design simply sent me a new fireplace which I installed. The thermal overheat cutoff feature occurs when the circuit board smokes itself and turns black LOL. If you can get a warranty replacement do so and keep your f fingers crossed. Good luck.
    John & Cindy
    2019 Reflection 303 RLS
    2018 Ford F250 6.7 PSD

  9. #9
    New Member
    Join Date
    Oct 2021
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I now have an issue!
    My Innoflame RV36D80F-C1 fireplace just had a "meltdown". Heat wouldn't work so I pulled it out and had a look/see. The power wire to the heater element must have gotten so hot the wire separated from the female spade lug and just dropped down only after melting through a nylon zip ty and all but turning the stranded aluminum wire into a solid wire! Also, plenty of "burn" residue on adjoining electrical components. This could have resulted in an actual fire! Starting the phone calls to GD today. This appears to be 16 gage wire at best that appears to be fairly overworked. The wire is "toast" for at least 2-3" up from the female spade connection, brittle and black! Not surprisingly, everything is labeled, "Made in China"...

  10. #10
    New Member
    Join Date
    Jan 2024
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Flyerboy View Post
    I now have an issue!
    My Innoflame RV36D80F-C1 fireplace just had a "meltdown". Heat wouldn't work so I pulled it out and had a look/see. The power wire to the heater element must have gotten so hot the wire separated from the female spade lug and just dropped down only after melting through a nylon zip ty and all but turning the stranded aluminum wire into a solid wire! Also, plenty of "burn" residue on adjoining electrical components. This could have resulted in an actual fire! Starting the phone calls to GD today. This appears to be 16 gage wire at best that appears to be fairly overworked. The wire is "toast" for at least 2-3" up from the female spade connection, brittle and black! Not surprisingly, everything is labeled, "Made in China"...
    I just pulled out the same model in my rig as it stopped producing heat. The white wire going to the heating element was burnt and brittle I imagine just like you found in your unit... in fact, the spade on the heater element itself had broken. I am wondering how your conversation with GDRV has gone in reporting your situation. The fan/heating element component I imagine along with some new higher guage wire would get the fireplace back up and running. The control and display boards look uneffected. Scary to think what could have happened. I guess I need to add a periodic maintenance item to pull fireplace and check wiring conditions. Argh.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

DISCLAIMER:This website is not affiliated with or endorsed by Grand Design RV, LLC or any of its affiliates. This is an independent site.